Suite

Quelle est la version correcte de jetty-servlets.jar pour GeoServer 2.6-RC1

Quelle est la version correcte de jetty-servlets.jar pour GeoServer 2.6-RC1


J'essaie de déterminer la version correcte de jetty-servlets à installer. J'ai installé GeoServer 2.6-RC1.

Maintenant, je dois installer jetty-servlets.jar pour activer CORS comme mentionné ici :

http://www.eclipse.org/jetty/documentation/current/cross-origin-filter.html

Il vous invite à télécharger le jetty-servlet ici :

http://central.maven.org/maven2/org/eclipse/jetty/jetty-servlets/

Quelle est la bonne version à télécharger si j'ai installé GeoServer 2.6-RC1 ?


J'ai trouvé une solution étonnante et facile pour déterminer la bonne version de jetty-servlets.jar pour GeoServer.

La solution est d'ouvrir le répertoire de la jetée

  • Windows : C:Program Files (x86)BoundlessOpenGeojettylib
  • OS X : /Utilisateurs//Bibliothèque/Application Support/GeoServer/jetty/lib

Vous trouverez des fichiers jar se terminant par la version jetty avant l'extension.

(aimer: jetée-client-7.6.13.v20130916.jar) pour Géoserveur 2.8.

  • Rappelez-vous le numéro de version du fichier (7.6.13.v20130916) et navigue vers cette URL et sélectionnez la version correspondant à la version que nous avons obtenue à la dernière étape.

  • Choisissez le fichier (comme : jetty-servlets-7.6.13.v20130916.jar ) aucun autre fichier n'est nécessaire.

Coller le téléchargé pot dans répertoire de la jetée


J'ai trouvé la bonne version ! Il s'agit de jetty-servlets-9.2.2.v20140723.jar.


Voir la vidéo: Marko Vanhanen Oudot sosiaaliset koukerot.