Suite

Solutions de contournement pour le plugin heatmap dans QGIS?

Solutions de contournement pour le plugin heatmap dans QGIS?


Dans QGIS 2.8, le plugin heatmap a cassé CRS. J'ai mis à jour vers la 2.10, maintenant dans le plugin la boîte de dialogue est cassée : elle ne permet pas de choisir le format.

Je rends les calques pour les atlas avec le style heatmap. Mais j'ai besoin de l'exporter vers GeoTIFF, et je ne vois pas comment le faire.

La mise à jour de QGIS n'est pas facile dans Ubuntu, car cela fonctionne normalement lorsqu'il est installé à partir d'un PPA, mais l'installation à partir des sources ou le téléchargement de debs est très pénible.

Y at-il un travail autour?

Un exemple de ligne de commande fera également l'affaire.

Éditer voici une capture d'écran. La liste des formats est vide, et si j'écris l'extension de fichier manuellement comme je l'ai fait ici, cela ne permet toujours pas d'afficher un message indiquant que le format n'est pas choisi.

Pendant ce temps, dans une autre boîte de dialogue, le choix du format fonctionne correctement :

Versions :


J'exécute QGIS 2.10 sur Linux Mint 17.2 (basé sur trusty), et dans le plugin Heatmap, la liste déroulante des formats disponibles n'est pas vide, donc votre problème n'est pas un problème général avec QGIS exécuté sur LM/Ubuntu. Je ne sais pas comment reproduire ce problème.

Cependant, vous suggérez que le problème est survenu après une mise à jour vers 2.10. Il me vient à l'esprit qu'une quantité importante de fonctionnalités de QGIS (en particulier pour les plugins) dépend depython-qgis. Cette pourrait expliquer la différence entre Heatmap (plugin) et Raster Calculator (qui, je crois, est essentiel), donc je vérifierais que vous avezpython-qgiscelui installé avec

politique apt-cache python-qgis

et installez-le s'il est manquant.

Une autre préoccupation est que vous dites que vous avez mis à jour la version 2.10 à partir du PPA ubuntugis-unstable. Cependant, pour autant que je sache, ubuntugis-unstable ne monte qu'à la version 2.8. Je ne sais pas pourquoi cela conduirait à une fonctionnalité incomplète. Peut-être que vous avez QGIS 2.10 maispython-qgis2,8 ? L'écart implique que vous n'avez peut-être pas installé à partir du référentiel que vous aviez prévu.

Si vous utilisez Ubuntu Trusty, je vous recommande d'installer la version 2.10 à partir du référentiel QGIS, mais commencez par purger votre installation actuelle :

sudo apt-get purge qgis python-qgis

Ajoutez ensuite les lignes suivantes à/etc/apt/sources.list:

deb http://qgis.org/ubuntugis trusty main deb-src http://qgis.org/ubuntugis trusty main

Remarque : bien que vous puissiez modifier/etc/apt/sources.listdirectement, en pratique je préfère utiliser l'outil Sources de logiciels (disponible en standalone ou depuis le menu Synaptic) pour ajouter de nouvelles lignes source de référentiel.

Après cela, mettez à jour et réinstallezqgisetpython-qgispackages via Synaptic ou :

sudo apt-get mise à jour sudo apt-get installer qgis python-qgis qgis-plugin-grass

Ces instructions sont extraites de http://qgis.org/en/site/forusers/alldownloads.html#debian-ubuntu. Je peux également confirmer qu'ils fonctionnent, car c'est ainsi que j'ai installé QGIS 2.10 sur LM 17.2. Il s'agit également des instructions pour la version conçue pour fonctionner avec les dépendances d'ubuntugis et nécessite l'utilisation du PPA ubuntugis-unstable, que vous utilisez déjà. Mais si vous utilisez une version d'Ubuntu plus récente que Trusty, vous devez choisir la version appropriée, et ne pas utiliser les dépendances d'ubuntugis. Consultez le lien pour plus d'instructions.


Voir la vidéo: Creating a Heatmap using QGIS